AnsweredAssumed Answered

FRDM-KL26Z eval board, openSDA not working.

Question asked by Andrew Parlane on Jan 27, 2014
Latest reply on Feb 1, 2014 by Erich Styger

I have a FRDM-KL26Z eval board. I'm running the openSDA bootloader v1.11

 

 

From SDA_INFO.HTML:

 

 

Board Name is: FRDM-KL26Z

MicroBoot Kernel Version is: 1.05

Bootloader Version is: 1.11

Installed Application: PEMicro FRDM-KL26Z Mass Storage/Debug App

Application Version is: 1.14

 

 

I can boot into bootloader mode, and into the SDA application. The mass storage device appears. I see the expected contents.

 

 

However when I copy an srec from the precompiled examples in the quick start package from the FRDM-KL26Z freescale page (http://www.freescale.com/webapp/sps/site/prod_summary.jsp?code=FRDM-KL26Z&tid=vanFRDM-KL26Z) the openSDA led blinks a couple of times to indicate activity, and then goes solid. However nothing else happens. I've tried a few different applications, but no serial output / the RGB LED doesn't light up.

 

 

Opening laststat.txt before copying the binary says: "ready", after copying the binary and waiting 5s the file still says "ready". Power cycling the board has no effect either, other than the srec no longer is on the drive.

 

 

The demo app that came with the board worked fine, so it only stopped working after I reloaded the openSDA app as instructed in the quick start guide.

 

 

Anyone have any ideas?

 

 

Thanks

Outcomes