AnsweredAssumed Answered

keyboard problem on i.MX6Q-SABRESD

Question asked by Xiaoqiang Yang on Jan 21, 2014
Latest reply on Aug 6, 2015 by Rejit Antony

Hi all,

 

I built my own rootfs by LTIB using profile 'FSL gnome release package', and started linux on i.MX6Q-SABRESD successfully. But when I pluged a usb hub to OTG port and pluged a usb mouse and a usb keyboard to the hub, the mouse worked well but the keyboard can not.

When I pluged the keyboard,I got some messages as below:

usb 1-1: new low speed USB device number 2 using fsl-ehci

usb 1-1: device v046d pc31c is not supported

input: Logitech USB Keyboard as /devices/platform/fsl-ehci.0/usb1/1-1/1-1:1.0/in

put/input9

generic-usb 0003:046D:C31C.0001: input,hidraw0: USB HID v1.10 Keyboard [Logitech

USB Keyboard] on usb-fsl-ehci.0-1/input0

input: Logitech USB Keyboard as /devices/platform/fsl-ehci.0/usb1/1-1/1-1:1.1/in

put/input10

generic-usb 0003:046D:C31C.0002: input,hidraw1: USB HID v1.10 Device [Logitech U

SB Keyboard] on usb-fsl-ehci.0-1/input1

 

Besides,I found that when I pressed <ALTF1> the screen became black and  <ALTF2> returned to gnome desktop.The NumLOCK and CapsLock indicator lights worked well,but I can't use other function such as typing words in xterm.

Any suggestions? Thanks in advance!

 

Xiaoqiang

 

Outcomes