AnsweredAssumed Answered

Failing download to target

Question asked by Clovis Boutin on Jan 19, 2014
Latest reply on Feb 25, 2014 by Clovis Boutin

Hello,

 

I recently acquired a TWR-K70F120M. I'm using Code Warrior Development Studio for MCU  v10.5 Special Edition.

Everything worked well with the Debug and Run options.

But when I manually reset the TWR, the program was no longer executed. So I tried to flash the program (bareboar project, no MQX, just the counter incrementation default code).

I specified the wrong file to flash on the target (the .project xml file). Since that moment, neither the Debug, Run, and Flash Program works (by specifying the right flash .elf file)

I already tried on another computer, with another CodeWarrior install, also tried to mass erase the target.

The error I get when trying to Flash Program is :

 

Downloading 0x000001E8 bytes to be programmed at 0x00000000  

Executing program ....

 

Error:  Program failed.   Flash driver reports the following error(s): The flash device algorithm was interrupted during execution.

Please check if the flash base address is correct or if there are any flash devices mapped inside the selected memory space.

If a custom target initialization file was used then check the following parameters: flash base address, flash bank size and flash

bank port size.

Please enable Verify Target Memory Writes in Target Configuration to check that the algorithm downloads correctly. If you are down

loading the algorithm to DDR try checking your DDR configuration.

 

With the Debugger Shell I'm able to read the Flash (using the display command) and the xml file is still there.

When trying to read registers one by one (reg command), the target disconnects itself.

A fl::blanckcheck command leads to an <internal error>.


I would like to know :

     - Where is located the program when Running or Debugging a program : is it sent instruction-per-instruction to the target ? or all goes in RAM even with the Flash build ?

     - By downloading the wrong file what could be the cause of my problem ?


Thanks in advance


Best Regards, Clovis

Outcomes