AnsweredAssumed Answered

DSC Flasher problems with USBTAP Rev 7, Windows XP, and MC56F8367

Question asked by Mike Fugere on Jan 7, 2014
Latest reply on Jan 24, 2014 by Mike Fugere

I guess I had in appropriately hopped onto an announcement thread on the DSC flasher, so that probably meant none of the solutions experts noticed it.  I will re-ask here in itw own thread - my apologies for

any breach of etiquette:

 

I seem to be having issues trying to get this to work on the (2) Windows XP machines I have tried so far.

In both cases, I am using the same USBTAP Rev F, and trying to program some 56F8367 DSC devices.

In one case, I also have Codewarrior 8.3 installed on the machine and regularly use it for development.   The USBTAP works fine with it and I am using CCS Version 4.13 build 363p0.

But, without CW or an instance of CCS running and simply trying to use the DSC Flasher to erase and program some DSCs, it will fail to do so with the following appearing in the console window:

Performing PROGRAM operation on MC56F8367 through the UTAP...

Error 9: CC config string is invalid

Make Sure your Device is Plugged-In and No Other Devices are Configured to the Run Control Device. Close all CCS Applications Prior to Flashing Target Device.

Changing the JTAG clock speed to various values as low as 100KHz has no effect.  CCS Timeout is still at 10 seconds.

 

On the other XP machine (which I am trying to configure for actual production usage) there has never been any CodeWarrior software installed.   I downloaded and installed the DSC flasher and the CCS USBTAP drivers according to the documentation.  The CCS version actually appears to be the same revision and build that is on the other XP machine.

Attempts to program several different DSC 56F8367 devices all result in the same error messages and failure on this machine - the console log shows:

Performing PROGRAM operation on MC56F8367 through the UTAP...

Error 9: Core not responding

Check that the Target Device Model Number Matches "MC56F8367"

If Model Numbers Match, Then UnPlug and Replug the Device

 

It doesn't matter if I cycle power to the target device, unplug/replug the USBTAP connector, or unplug/replug the USBTAP itself - any other attempts result in the same outcome. It won't work.  It will (apparently) Mass erase the DSC OK, but always fails as soon as it starts to write to program flash.   The results are identical if I use the command line interface or the GUI interface.

 

I know that the S-record file is good, the target hardware is good, and the USBTAP is good because I can use my CodeWarrior 8.3 to debug, program, erase, etc. all of these target PCBs.   But, my intent is to use the DSC flasher for production programming use - and it appears to have problems.

Any assistance you can provide is much appreciated!

 

Mike F

Outcomes