AnsweredAssumed Answered

Ethernet RMII Mode on TWRK70F120M

Question asked by HU Q on Dec 20, 2013
Latest reply on Mar 4, 2014 by David E Seymour

Hi

 

I am trying to run Ethernet Device on TWRK70F120M with RMII Mode Enabled.

 

Currently My CPU is running in PEE mode [Serial, I2C, SPI devices are running]


I have done following jumper settings on K70 Board

J18: OFF

J19: OFF

 

I have done following jumper settings on TWR-SER board

J2: 3-4

J3: 2-3

J12: 5-6, 9-10

 

I have done following configurations for Ethernet in Ethernet code.

 

/* Select ALT 4 function on PTB1 for RMII_MDC */

/* Select ALT 4 function on PTB0 for RMII_MDIO */

/* Select ALT 4 function on PTA14 for RMII_CRS_DV */

/* Select ALT 4 function on PTA13 for RMII_RXD0 */

/* Select ALT 4 function on PTA12 for RMII_RXD1 */

/* Select ALT 4 function on PTA5 for RMII_RXER */

/* Select ALT 4 function on PTA16 for RMII_TXD0 */

/* Select ALT 4 function on PTA17 for RMII_TXD1 */

/* Select ALT 4 function on PTA15 for RMII_TXEN */

/* Enable RMII_REF_CLK / OSC0ERCLK clock in SIM_SOPT2 Register[TIMESRC[ */

/* Enable ENET Clock in SIM_SCGC2 register  */

 

 

 

Am I missing any jumper settings?

Am I missing any configurations related to CPU or Ethernet?

Am I missing clock configurations like CLKIN0 (PTA18)?

 

My CPU driver stuck if I do above jumper settings because [MCG_S[IREFST] bit is not getting low [Source of FLL reference clock is the external reference clock] and PHY of Ethernet is not getting UP.

Outcomes