AnsweredAssumed Answered

u-boot NFS problem

Question asked by Massimo Cristofolini on Dec 13, 2013
Latest reply on Dec 18, 2013 by Rita Wang

Hi everyone,

 

I have a SABRE IMX6Q, that was correctly working with NFS.

Now I messed up the u-boot parameters, and I'm not able to let it work again.

Here is the output of the 'pr' command in u-boot

 

baudrate=115200

boot_fdt=try

bootargs=console=ttymxc0,115200 root=/dev/nfs ip=10.0.10.216:10.0.10.108:10.0.10.1:255.255.255.0:sabresd:eth0:off:nfsroot=${serverip}:{nfsroot},v3,tcp

bootcmd=mmc dev ${mmcdev};if mmc rescan; then if run loadbootscript; then run bootscript; else if run loaduimage; then run mmcboot; else run netboot; fi; fi; else run netboot; fi

bootdelay=1

bootfile=uImage

bootscript=echo Running bootscript from mmc ...; source

console=ttymxc0

ethact=FEC

ethaddr=00:04:9f:02:b2:f0

ethprime=FEC

fdt_addr=0x11000000

fdt_file=imx6q-sabresd.dtb

fdt_high=0xffffffff

get_cmd=tftp

initrd_high=0xffffffff

ip_dyn=no

ipaddr=10.0.10.216

loadaddr=0x12000000

loadbootscript=fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${script};

loadfdt=fatload mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${fdt_file}

loaduimage=fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${uimage}

mmcargs=setenv bootargs console=${console},${baudrate} root=${mmcroot}

mmcboot=echo Booting from mmc ...; run mmcargs; if test ${boot_fdt} = yes || test ${boot_fdt} = try; then if run loadfdt; then bootm ${loadaddr} - ${fdt_addr}; else if test ${boot_fdt} = try; then bootm; else echo WARN: Cannot load the DT; fi; fi; else bootm; fi;

mmcdev=1

mmcpart=1

mmcroot=/dev/mmcblk1p2 rootwait rw

netargs=${bootargs}

netboot=echo Booting from net ...; run netargs; if test ${ip_dyn} = yes; then setenv get_cmd dhcp; else setenv get_cmd tftp; fi; ${get_cmd} ${uimage}; if test ${boot_fdt} = yes || test ${boot_fdt} = try; then if ${get_cmd} ${fdt_addr} ${fdt_file}; then bootm ${loadaddr} - ${fdt_addr}; else if test ${boot_fdt} = try; then bootm; else echo WARN: Cannot load the DT; fi; fi; else bootm; fi;

nfsroot=/home/cristofolini/tftp

script=boot.scr

serverip=10.0.10.108

uimage=uImage

update_sd_firmware=if test ${ip_dyn} = yes; then setenv get_cmd dhcp; else setenv get_cmd tftp; fi; if mmc dev ${mmcdev}; then if ${get_cmd} ${update_sd_firmware_filename}; then setexpr fw_sz ${filesize} / 0x200; setexpr fw_sz ${fw_sz} + 1; mmc write ${loadaddr} 0x2 ${fw_sz}; fi; fi

 

Environment size: 2098/8188 bytes

 

 

uBoot isn't able to locate uImage.

uImage is copied in my tftp directory, the one listed in /etc/default/atftpd.

Then, the fyle system is in nfsroot=/home/cristofolini/tftp, and the directory is exported in /etc/exports

 

Am I missing something?

Thanks for the support!

MIX

Outcomes