AnsweredAssumed Answered

Windows Media Player ActiveX Control on i.MX53 running CE 7

Question asked by Tim Jaacks on Dec 12, 2013
Latest reply on Mar 6, 2014 by Justin Jiang
Branched to a new discussion

Hello,

 

I want to play videos in a browser window on the i.MX53 Quick Start Board running Windows CE. I use the Adeneo Windows CE 7 BSP 1.22. To activate the ActiveX control, I selected SYSGEN_MEDIAAPPS_WMPOCX in my OS design. However, playing videos using the ActiveX control does not work. I tried it in the browser (embedded into an HTML document using <OBJECT ID="Player" CLASSID="CLSID:6BF52A52-394A-11d3-B153-00C04F79FAA6">), in a .NET application and in a native C++ application. In all three cases, the same error appears as soon as the URL of the video to play is passed to the media player object: REGDB_E_CLASSNOTREG (0x80040154). The ActiveX control itself is visible (buttons, status bar, video window).

On our custom i.MX27 board running Windows CE 6 based on the Freescale BSP, playing videos via the ActiveX control works fine.

Has anybody experienced similar problems on the i.MX53? Any clues on how to fix this issue?

Maybe it would already help if anyone knew how to find out which class is not registered. It cannot be the Media Player class itself, because it is visible, though.

 

Best regards,

Tim

Outcomes