AnsweredAssumed Answered

gstreamer, screen resolution and other issues

Question asked by Eugene Solotchin on Dec 12, 2013
Latest reply on Dec 18, 2013 by Leonardo Sandoval Gonzalez

Sabre SmartDevice board with Quad Core.

I'm experiencing strange problems with  Oneiric (4.1.0); kernel 3.0.35-2666-gbdde708.

Sterile installation right from archives on clean SD card.

 

I'm looking here:

https://community.freescale.com/docs/DOC-93387

And here:

https://community.freescale.com/docs/DOC-93788

 

I'd discovered, that command

 

gst-launch playbin2 uri=file://sample-video.avi video-sink="mfw_isink axis-top=0 axis-left=0   disp-width=320 disp-height=240"

 

does *NOT* render any video on my screen and doesn't report any problems (exept one audiosystem issue) either. CPU load approx 1..3%. But

 

 

gst-launch playbin2 uri=file://sample-video.avi video-sink="mfw_v4lsink axis-top=0 axis-left=0   disp-width=320 disp-height=240"

 

renders requested video normally, without lag, without frame drop, CPU load approx 10..15% and sreccn resolution is 640x480. I can't set higher screen resolution, and this is a second problem.

 

[Freshly installed from repo] VLC can't render any picture at all, or rendering it with almost 100% CPU load and frame drops (depends on Preferences/Video settings).

 

Second problem. I can't change screen resolution to other than 640x480@60. My monitor (pretty old, but still alive LCD) can do 1024x768@60. I've tested a few other systems, all of them can properly detect and set correct screen resolution via HDMI->VGA converter cable. On the other hand, i can manually edit /etc/X11/xorg.conf, and it rocks... but after a 20..30 second (or even less) screen starts flicker (looks like moni losing synchronization, but why?!)

More of that, mouse cursor leaving the trails (multiple inactive images of cursor arrow and so on). I've tried to set/unset hardware cursor option - no result. I've tried to change hsync/vsync flags - no result.

 

My moni DOES SUPPORT 1024x768@60 and other systems have no such problems at all.

 

Third problem: system tells me that release is obsolete (11.10) and asking.. not, BEGGING me for update to LTS 12.04. I've tried that once, but after update (with a few minor bugs with it) I've lost support of 3D hardware.

 

/var/log/Xorg.0.log says that vivante_drv.so was compiled for other X.org and refuses to load.

Outcomes