AnsweredAssumed Answered

imx6q multicore test in platform SDK is not working

Question asked by Dean Chu on Dec 9, 2013
Latest reply on Mar 1, 2014 by Dean Chu
Branched to a new discussion

Hello all,

 

I'm trying to run the multicore test from the platform SDK v1.1 on my SABER-SDB rev A (i.MX6Q).

I built the bin file with "./tools/build_sdk -t mx6dq -b smart_device -board_rev a". And downloaded "./output/mx6dq/sdk_unit_test/smart_device_rev_a/sdk_unit_test_ALL.bin" to an SD card with cf_imager.

 

"cfimager -raw -f ./sdk_unit_test_ALL.bin -d i -a"

 

The board boots perfectly, and other tests works fine. But when it comes to the multicore test, the program stuck after CPU0 sent SGI to CPU1.

 

Select test to run:

mc

Running the GIC Multicore Test

Starting and sending SGIs to secondary CPUs for "hello world"

 

secondary main cpu: 1

secondary main cpu: 2

secondary main cpu: 3

Hello from CPU 0

 

"secondary main cpu: x" indicates that all CPUs are on, but it seems CPU1 dosen't  receive any SGI signal or maybe the gic isn't initialized properly on CPU1.  I didn't modify any code of the platform SDK, and i have re-downloaded the SDK and tried again, but it was still not working.

 

Has anyone runs the multicore test successfully? I need some hints.

 

Thanks

Dean Chu

Outcomes