AnsweredAssumed Answered

MQX 4.0.2 can't open SPI2

Question asked by Sandro Bastos on Dec 5, 2013
Latest reply on Dec 6, 2013 by Sandro Bastos

Hi,

 

I'm using TWR-VF65GS10 with IAR and MQX 4.0 and only can open SPI0 with "fopen ("spi0:", NULL)", if I try to open "spi1:" or "spi2:" the fopen() returns NULL.

 

Yes, I already enabled them im 'user_config.h', rebuilt, and I've checked in 'init_bsp' and they are being installed:

 

#if BSPCFG_ENABLE_SPI0

    _io_spi_install("spi0:", &_bsp_spi0_init);

#endif

 

#if BSPCFG_ENABLE_SPI1

    _io_spi_install("spi1:", &_bsp_spi1_init);

#endif

 

#if BSPCFG_ENABLE_SPI2

    _io_spi_install("spi2:", &_bsp_spi2_init);

#endif

 

My code is running at the A5 processor.

 

Any idea?

Outcomes