Marshall Schiring

M68DEMO908GB60. - SCI Data Register Problem

Discussion created by Marshall Schiring on Aug 3, 2007
Latest reply on Aug 3, 2007 by David Payne
EDIT: accidentally hit enter instead of tab

Hey All:
First off sorry if this is in the wrong forum.
I am using M68DEMO908GB60.

I am simply trying to retrieve a data byte sent over serial cable via RxInterrupt.
I have my interrupt set up correctly - it triggers and runs through it properly.
I have checked the baud rates over many times - 19200 (have also tried 9600)

Here is the problem:
When I check (in memory in debug mode) when I send a byte it writes to the SCIxD correctly.
Only when I send the byte 0x7E (the most crucial byte of course...) the register then reads "0xFE".
I remember having a similar problem before when writing 0x00 and the register actually writing 0x80 (same problem as in the most significant bit is a 1 when it should be a 0) and it magically fixed itself.... (as the 0x00 byte was not important - I was able to continue with my program, the 0x7E byte, however, is needed to continue execution)


I've tried both SCI ports and multiple cables - same problem.

Wondering what may cause this?

Thanks in advance.



Message Edited by Tacky on 2007-08-03 04:14 PM

Added part number to subject.



Message Edited by NLFSJ on 2007-08-03 10:17 AM

Outcomes