AnsweredAssumed Answered

enable usb wifi in imx6Q sabrelite

Question asked by shanmugamsundar on Nov 16, 2013

hi all,

 

      I am using IMX6q Sabre lite board i need to configure the usb wifi in imx board, for that i try to interface the Atheros usb wifi dongle ZD1211RW the corresponding driver and firmware get loaded and give the commands to search the wifi network and to connect that steps i tried are


Output for driver& firmware loaded

usb 2-1.2: new high speed USB device number 3 using fsl-ehci

usb 2-1.2: print_id() 0ace:1215 v4810 high

usb 2-1.2: reset high speed USB device number 3 using fsl-ehci

zd1211rw 2-1.2:1.0: zd_chip_read_mac_addr_fw()

ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'

zd1211rw 2-1.2:1.0: probe() successful

zd1211rw 2-1.2:1.0: phy0

 

ifconfig wlan0 up

 

zd1211rw 2-1.2:1.0: firmware version 4725

zd1211rw 2-1.2:1.0: zd1211b chip 0ace:1215 v4810 high 00-e0-4c UW2453_RF pa0 g7---

 

Step1:-

 

iwlist scan

 

O/P of the above command:-

 

wlan0     Scan completed :

          Cell 01 - Address: F0:7D:68:45:38:EE

                    Channel:9

                    Frequency:2.452 GHz (Channel 9)

                    Quality=66/100  Signal level=66/100

                    Encryption key:on

                    ESSID:"OVIYA-WIFI"

                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s

                              18 Mb/s; 36 Mb/s; 54 Mb/s

                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb   Mode:Master

                    Extra:tsf=0000000499f8faca

                    Extra: Last beacon: 660ms ago

                    IE: Unknown: 000A4F564959412D57494649

                    IE: Unknown: 010882848B961224486C

                    IE: Unknown: 030109

                    IE: Unknown: 32040C183060

                    IE: Unknown: 0706474220010D10

                    IE: Unknown: 33082001020304050607

                    IE: Unknown: 33082105060708090A0B

                    IE: Unknown: DD050050F20500

                    IE: Unknown: DD130050F204104A00011010440001021041000100

                    IE: Unknown: 050400010000

                    IE: Unknown: 2A0100

                    IE: Unknown: 2D1AEE1117FF000000010000000000000000000000000C0000000000

                    IE: Unknown: 3D1609070600000000000000000000000000000000000000

                    IE: Unknown: 7F0101

                    IE: WPA Version 1

                        Group Cipher : TKIP

                        Pairwise Ciphers (2) : CCMP TKIP

                        Authentication Suites (1) : PSK

                    IE: IEEE 802.11i/WPA2 Version 1

                        Group Cipher : TKIP

                        Pairwise Ciphers (2) : CCMP TKIP

                        Authentication Suites (1) : PSK

                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00

                    IE: Unknown: 0B0503003A127A

                    IE: Unknown: DD1E00904C33EE1117FF000000010000000000000000000000000C0000000000

                    IE: Unknown: DD1A00904C3409070600000000000000000000000000000000000000

                    IE: Unknown: DD07000C4307000000

 

Step2:-

 

And i add the following lines in  the etc/network/interfaces file

 

auto wlan0

iface wlan0 inet dhcp

wpa-driver wext

wpa-conf managed

wpa-ssid OVIYA-WIFI

wpa-ap-scan 2

wpa-proto TKIP

wpa-pairwise TKIP

wpa-key-mgmt WPA-PSK

wpa-psk F0:7D:68:45:38:EE

 

 

and i run the command

 

ifconfig wlan0 up   it gives the output

 

udhcpc (v1.20.2) started

Sending discover...

Sending discover...

Sending discover...

No lease, failing

 

Can any tell me what is this error means, i need any extra tools to enable the wifi or i need to configure the interface file correctly plz suggest any idea

 

Thanks,

shan

 

Message was edited by: Shanmugam sundar

Outcomes