AnsweredAssumed Answered

MC9S12E128 - Cannot Unsecure

Question asked by Andy McNeil on Nov 4, 2013
Latest reply on Nov 5, 2013 by Andy McNeil

I am getting an error when I try to download & debug a target using the MC9S12E128. As best as I can determine, it's because I cannot unsecure the MC9S12E128.

 

Here is my setup. Target is a an in-house board using a MC9S12E128. Host is a Windows XP SP3 workstation. Using a Cyclone Pro ICD via USB cable from host and 6-pin BDM connector from ICD to target. I am using CodeWarrior CW12_v3.1. When I go to download my build, the debugger eventually times out and issues the errors as follows:

   

     Hi-WAVE Failed to find communication speed!


     Hi-WAVE Communicationto the target has failed

     (target MCU has no clock or wrong BDM clock speed is used

     or derivative is secured!)

 

     There is currently no Target connected.

     Please, connect a Target before loading an executable file.


BTW, I'm new to my position. I am an experienced embedded systems developer, just new to Freescale.


I did some searching and reading and believe that the problem is the debugger is not connecting to the MCU and then unsecuring it. I've tried changing settings via the debugger interface (True-Time) but can't get it to work. I then found the P&E Micro Unsecure 12 but can't get it to work either. I get the following error:


ERROR - Communicating with target.

Appropriate interface speed not found.


I have tried different speeds but nothing works. I still believe it's a clock/speed setting just don't know what it is.

 

Any answers or suggestions?

 

Andy McNeil | Systems Engineer

Spotwave Wireless Inc.

Kavveri Telecom Products Limited

  1. P.O. Box 550

500 Van Buren Street

Kemptville, ON K0G 1J0

CANADA

T 613.591.1662 ext. 3336

F 613.258.7418

E andy.mcneil@kaveritelecoms.com

Outcomes