AnsweredAssumed Answered

i.MX6 SDB board uImage not loading

Question asked by PRAMOD KUMAR on Oct 31, 2013
Latest reply on Oct 31, 2013 by raymond wang

Dear All,

I am working i.MX 6Quad SABRE-SD board load the u-boot and uImage as given below

 

sudo dd if=u-boot-mx6q-sabresd.bin of=/dev/sdc bs=512 seek=2 skip=2 conv=fsync

sudo dd if=uImage of=/dev/sdc bs=512 seek=2048 conv=fsync

 

u-boot is working and uImage not loading

U-Boot 2009.08 (Jul 25 2013 - 03:59:03)

CPU: Freescale i.MX6 family TO1.2 at 792 MHz
Thermal sensor with ratio = 179
Temperature:   53 C, calibration data 0x56d4b77d
mx6q pll1: 792MHz
mx6q pll2: 528MHz
mx6q pll3: 480MHz
mx6q pll8: 50MHz
ipg clock     : 66000000Hz
ipg per clock : 66000000Hz
uart clock    : 80000000Hz
cspi clock    : 60000000Hz
ahb clock     : 132000000Hz
axi clock   : 264000000Hz
emi_slow clock: 132000000Hz
ddr clock     : 528000000Hz
usdhc1 clock  : 198000000Hz
usdhc2 clock  : 198000000Hz
usdhc3 clock  : 198000000Hz
usdhc4 clock  : 198000000Hz
nfc clock     : 24000000Hz
Board: i.MX6Q-SABRESD: unknown-board Board: 0x63012 [POR ]
Boot Device: SD
I2C:   ready
DRAM:   1 GB
MMC:   FSL_USDHC: 0,FSL_USDHC: 1,FSL_USDHC: 2,FSL_USDHC: 3
*** Warning - bad CRC or MMC, using default environment

In:    serial
Out:   serial
Err:   serial
i2c: I2C3 SDA is low, start i2c recovery...
I2C3 Recovery success
Found PFUZE100! deviceid=10,revid=11
Net:   got MAC address from IIM: 00:04:9f:02:6b:22
FEC0 [PRIME]
Hit any key to stop autoboot:  0
PHY indentify @ 0x1 = 0x004dd074
FEC: Link is Up 796d
Using FEC0 device
TFTP from server 192.168.1.101; our IP address is 192.168.1.103
Filename 'uImage'.
Load address: 0x10800000
Loading: T T T T T T T T

 

I have load the uImage in SD card but kernel not bootinh

Outcomes