AnsweredAssumed Answered

Asm("sc;"); system call exception

Question asked by Pierre-Antoine Minichetti on Oct 30, 2013
Latest reply on Oct 30, 2013 by Pierre-Antoine Minichetti

Hi,

 

As i was reconfigurating the DDR on a default codewarrior project i came up with à little problem.

 

In the default configuration, the DDR(interleaved controllers) is mapped  from 0x0000_0000 to 0x7FFF_FFFF.

What I did was to remap the DDR from 0x0000_0000 to 0x3FFF_FFFF (which is 1GB or 512MB per controller)

I also disabled the interleaving mode which means each DDR controller is assigned 512MB of space (DDR1 from 0x0000_0000 to 0x1FFF_FFFF and DDR2 from 0x2000_0000 to 0x3FFF_FFFF)

 

The code start addresses were changed in the .lcf file according to the new DDR mapping. DDR1 unchanged but DDR2 changed from 0x40XX_XXXX to 0x20XX_XXXX (code, heap and stack, etc.)

 

When i run the default main(), core1 is stuck at adresse 0x...X_4000_0700 when executing asm("sc;"), command.

 

When I run the project without the asm("sc";); command on core1 it works fine. (the command does work on core0 because it jumps to adress 0x...X_0000_0700)

 

Does any one know what is missing to make it work ?

 

Thanks

Outcomes