AnsweredAssumed Answered

Error 17926 with a external mcu on FRDM Board..

Question asked by Franco De Rosa on Oct 23, 2013
Latest reply on Oct 25, 2013 by Franco De Rosa

Hi! This is my first post. I do not write English very well so I am using a translator.

I commented that I am using CodeWarrior 10.5 with KL25Z FRDM.

To start from scratch, a few months ago, create a project with Processor Expert for KL25Z plate using Code Warrior 10.3. I compile and debug without problems. With the same board i debug external MCU. This was a KL05Z, I read the User Guide from the FRDM KL25Z and it said it was to cut a track J11, it worked perfect, I could debug. The cable VCC, GND, SWD_DIO, SWD_CLK and RESET were connected from the FRDM towards external KL05 pin. As shown in the attached image.

 

IMG_20131023_152530.jpgIMG_20131023_160055.jpg

This was a few months ago, now install the new CodeWarrior 10.5.

Using the same FRDM, I could download a code without problems KL25Z FRDM interno.tilizando it, I could download a code without internal KL25Z problems.

The problem begins when I try to use an external MCU, the connection is the same he had used before, the external MCU is the same (KL05Z), the problem is that the MCU does not recognize me .. Or so I think.

 

Error 17926.pngError 17926  2.png

 

The CodeWarrior detected OpenSDA (I can debug the internal KL25Z FRDM), but produces the error 17926 (Picture Attached). Try installing in a virtual machine the CodeWarrior 10.3, but it gives me the same error, in the CodeWarrior 10.3 17926 Error window says, too, "Target MCU mismatch. OpenSDA debugging hardware supports only the resident target processor".

 

 

I checked all the connections between the FRDM and external MCU. Tensions are fine. The truth may be not understand that, try another FRDM KL25Z a colleague, but neither worked.

 

 

Thank you very much, hope you can help me. Greetings!
Franco.

Outcomes