AnsweredAssumed Answered

Failed to resume target process., ARM GDI Protocol Adapter : An error occurred while trying to write memory. The Debugger can not write memory.

Question asked by Carlos Rodriguez on Oct 23, 2013
Latest reply on Nov 23, 2013 by Alexander Gutor

I'm creating a new project 'deleteme' as a Bareboard project for my KL15Z128 design... I cannot seem to debug, I haven't touched the project initial code...

 

The funny thing is my CW 10.4 was working great just 3 weeks ago with my prototype, now it doesn't since I connect my prototype that worked ok with mi CW 10.4 and now it doesn't work!

 

I haven't touched the project since the last time it worked 3 weeks ago... did something expired in my CW instalation, or did it automatically update to something that doesn't work now???

 

Following the complete output of the J-Link trace:

 

 

Executing Initialization File: C:\Users\Carlos\workspace\deleteme1/Project_Settings/Debugger/init_kinetis.tcl

radix x

cmdwin::eclipse::config hexprefix 0x

cmdwin::eclipse::config MemIdentifier p

cmdwin::eclipse::config MemWidth 32

cmdwin::eclipse::config MemAccess 32

cmdwin::eclipse::config MemSwap off

cmdwin::reg User\/System Mode Registers/LR = 0xFFFFFFFF

failed on register write: LR

cmdwin::reg Breakpoint Unit Registers/BP_COMP0 = 0x0

failed on register write: BP_COMP0

cmdwin::reg Breakpoint Unit Registers/BP_COMP1 = 0x0

failed on register write: BP_COMP1

cmdwin::reg Core Debug Registers/DEMCR = 0x1000001

failed on register write: DEMCR

cmdwin::reg Data Watchpoint and Trace Unit Registers/DWT_FUNCTION0 = 0x0

failed on register write: DWT_FUNCTION0

cmdwin::reg Data Watchpoint and Trace Unit Registers/DWT_FUNCTION1 = 0x0

failed on register write: DWT_FUNCTION1

 

Please Help!

 

Carlos

Outcomes