AnsweredAssumed Answered

Rebuild EWL for Coldfire V1+

Question asked by Christian Becker on Oct 16, 2013
Latest reply on Oct 24, 2013 by Pascal Irrle

Hello everybody,

 

currently I`ve trying to rebuild the standard EWL libraries.

 

The reason was, I've got Compiler Warnings as they`re described in

https://community.freescale.com/thread/300543

 

Source file >"D:\workspace\ColdFire\ColdFire_Build_Tools\ewl\EWL_Runtime\..." not found, cannot display source

 

So I've tried as suggested:

 

  • Import project located in {Install}\MCU\ColdFire_Support\ewl in CodeWarrior
  • Click right on the project name then select Build Configuration > Set Active and select the appropriate configuration. This depend on the run time library file you are linking with your application.
  • Build the project to create a new .a file. All the debug information will then point to your current installation directory and you should be able to link your application

 

with Build Configuration "CF_EWL_C" I could build without errors, and also the warnings for the EWL C Library disappears in my project.

 

But any other Build Configuration failed, Ive tried "CF_EWL_RUNTIME" (because had 4 warnings referenced to it) but build failed with 3 Errors:


make: *** [all] Error 2    coldfire_lib             C/C++ Problem

make[1]: *** [v1/librt] Error 2

make[2]: *** [Runtime_CF_CmdLineData/v1/librt/obj/MWException.o] Error 1

 

Does anyone have a solution to build the EWL library project successfully?

 

I've testedd with Codewarrior for MCU V10.4 and V10.2, same results.

 

Best regards,

 

Christian

Outcomes