AnsweredAssumed Answered

socket mqx 4.0.2 routing problem with new modem ADSL Telecom Italia

Question asked by Manuel Moschin on Oct 9, 2013
Latest reply on Oct 21, 2013 by Martin Latal

Hi

i'm running the RTCS MQX 4.0.2 demos on a TWRK60 twrk60n512
and there are routing problems with new generation adsl modem:

 

adb broadcast modem adsl 2+ wi-fi TELECOM Italia.

 

with an old DLINK router the SMTP demo works and sends email correctly.

 

with the new router i'm NOT able to open a socket on SMTP port and send emails.

 

- all firewall are disabled, and set the default
configuration on router

 

- I tried on SMTP 576, and FTP, HTTP ports and the socket
connect fails too.

 

- I tried the NTP function and works correctly (the NTP
request is routed correctly and i received the sync and update
time)

 

Very starnge:

I connect an old windows 2000 pc in the same net and TELNET
port 25 correctly to the SMTP server

 

- looking with wireshark the pc packet mainly differs from
RTCS for the DON'T FRAGMENT flag SET

 

 

- I set the pc ip-address to TWR and switch cables: the SMTP
connection works, for a timeout of about 5 seconds... (NAT???)

 

 

 

- I have tried to enabling:

 

                #define RTCSCFG_ENABLE_VIRTUAL_ROUTES 1

 

                #define RTCSCFG_ENABLE_IGMP     1

 

                #define RTCSCFG_ENABLE_IPSEC    1

 

 

                and apply the patch to tcp_send.c found in
"connect socket mqx 4.0.2 problem" question

 

 

but the socket fails to connect

 

1) there are network protocols i have to add/enable in
RTCS?

 

2) it's possible to set/disable the fragment
option?

 

3) the router configuration is very simple: there are
particular services i have to check/disable?

 

4) any ideas for workaround?

 

this could be a router bug... but it's very strange, and this is the default TELECOM (italy) adsl router in business application

 

thank you

 

Manuel Moschin

Outcomes