AnsweredAssumed Answered

Hello world example on FRDM-KL46Z prints strange characters

Question asked by Carlos Mendoza on Oct 5, 2013
Latest reply on May 12, 2017 by Mark Sample

Hello all,

 

The hello world example source code is printing strange characters on the terminal. I get the "KL46 Hello World" message on the terminal followed by a continuous stream of "ÿ" (a letter "y" with an umlaut - the two dots on top). I can only get the stream of "ÿ" characters to stop by stopping the debugging session within CodeWarrior.

 

The first time I imported the project I got it to work correctly. I configured the terminal (I'm using PuTTY) according to the accompanying "FRDM-KL46Z_CW_rev1" PDF and I got the hello world message and I could see that any character I typed was echoed to the terminal followed by a character return/new line feed.

 

Today I opened up the project again and I get the described error. Strangely, I have made no changes to the code, or project settings (at least not that I was aware of). What's even stranger is that I have deleted all the examples and then re-installed them and I still get the same error. I re-installed the examples by running the KL46_SC.exe file that one can download from the freescale.com/frdm-kl46z website. One would think that by re-installing the files one would eliminate the possibility of having changed the code or settings on the previous install.

 

For accuracy's sake:

-I'm using CW 10.5 Special Edition.

-My PuTTY v0.62 serial terminal session is configured to 115200 baud, 8 data bits, 1 stop bit, no parity bits and no flow control. It is running on COM16 since that's what Windows 7's Device Manager shows for the OpenSDA CDC serial port. This is all according to the "FRDM-KL46Z Sample Code Guide for CodeWarrior Rev.1" PDF.

 

Like I said, I saw the program run perfectly fine yesterday.

 

I haven't tried re-installing CodeWarrior because that seems overkill just to get an example running again. But I'll do it if I have to. I'm not aware of making any changes to CodeWarrior's settings except that I made the font for the code bigger since the default size is too small for me. Anyway I restored the font settings by clicking on "Restore Defaults" on the Preferences > General > Appearance > Colors and Fonts options.

 

The only thing I can think of is that maybe some Windows app is printing the "ÿ" character and perhaps the CodeWarrior project etc are all fine. I have already restarted my computer and even plugged in the FRDM-KL46Z board onto a different port (it showed up as COM17) and the problem is still the same. I know that there's no keystroke stuck on my keyboard because otherwise I wouldn't be able to type this post without getting the "ÿ" character to overload the screen. I am running the OpenSDA debug app like it was mentioned in the PDF guide.

 

Any suggestions would be appreciated. I will post an answer if I find the solution myself so everybody can benefit.

 

Thanks,

Carlos

Outcomes