AnsweredAssumed Answered

Control GPIO on MQX side

Question asked by Bruno Castelucci Employee on Sep 30, 2013
Latest reply on Oct 30, 2013 by Bruno Castelucci

Hello, we are having trouble to control an GPIO from MQX, having the Linux BSP already running.

 

Our application first boots Linux kernel, then calls MQX from Linux command line, which means that Linux kernel initialization runs first.

 

What we need to do is to control an specific GPIO state from MQX, lets say as example PTC31.

 

When we try to simply do the regular GPIO initialization on MQX, without any change on Linux side, the application does not work.

We think the Linux initialization is taking control of that GPIO somehow, and when MQX tries to use it, it is denied.

 

When we tried on the same application, to control the same GPIO, but this time using the Linux /sys structure, it worked fine.

 

What would be the necessary steps to have this working?

Should we necessarily remove this GPIO from the Linux GPIO mapping? (on devices.c and board-twr-vf700.c at .../twr_vf600/kernel-source/linux-3.0/arch/arm/mach-mvf)

 

Thanks!

Bruno

Outcomes