AnsweredAssumed Answered

Reviving a newly opened but seemingly dead FRDM-KL46Z

Question asked by Carlos Mendoza on Sep 26, 2013
Latest reply on Oct 7, 2013 by Carlos Mendoza
Branched to a new discussion

Hello everyone,

 

I'm hoping to revive a fresh out of the box FRDM-KL46Z board which no longer powers up or is either recognized when I plug it in through the SDA USB port. I doubt I'm the only who's in a similar situation. The board stopped working after about 10 minutes of me opening it for the first time.

 

Here's the events between opening the box to the point where the board stopped working:

 

The demo app loaded and executed fine when I first plugged the board. Then I followed the Quick Start Guide's advice and copied a precompiled srec file unto the FAT drive. In my case this was the low_power_demo_freedom.srec file. While copying the file the board's yellow light was blinking. When the copying was done the board stopped blinking and I didn't notice any other reaction from the board. I then followed the guide's advice again and copied the FRDMKL46_Demo_freedom.srec file unto the memory. The board's light blinked while the copying was in progress. When the copying was done the light stopped blinking but the demo app was not running (i.e., the LCD was off and pressing SW1 did not scroll through the demo features). At this point I had two srec files on the FAT drive. The low power app and the out-of-the-box demo. So I deleted them from the FAT drive and recopied the demo but again the app did not execute. I then tried to eject the FAT drive but I noticed Windows 7 would not eject it. So I unplugged it and plugged it back in and tried to copy the lower power demo to no success and again the original demo also to no success. I then unplugged the board and plugged it back in while holding down the reset button so I could look into the SDA_INFO file. Being a newbie I didn't see anything interesting except that the board's light was blinking. I then tried to copy the demo app unto the FAT but again the app did not execute. I tried to eject the board and Windows 7 wouldn't eject it.

 

Finally (sorry for the long story but it's for the sake of accuracy) I just unplugged the board and plugged it back in. Unfortunately this time the board did not come on and Windows did not recognize it as a FAT drive (or anything at all). Unplugging it and plugging it back in does not solve anything.

 

It seems like the board is either bricked or dead. By the way, I'm using an anti-static arm band so I don't think this is the result of ESD.

 

I do embedded systems design for a living so I don't mind any suggestions involving checking the board with multimeters, oscilloscopes, using an external power supply, etc.

 

Thanks in advance! Any suggestions would be appreciated. I doubt that it is this easy to completely damage the board within 10 minutes of opening the box for the first time So I hope I can bring this little guy back to life!

Outcomes