AnsweredAssumed Answered

Help with K70 tower board

Question asked by Vlad Carpiuc on Sep 20, 2013
Latest reply on Oct 3, 2013 by Carlos_Musich
Branched from an earlier discussion

Hello everyone!

I have a K70 tower board with a Cortex M4. I have installed CodeWarrior 10.4 and MQX 4.0.2. I tried to configure my CodeWarrior to work with MQX but I cannot get it working.

This is what I have done:

1. Installed CW 10.4.

2. Installed MQX 4.0.2.

3. Updated CW with Kernel Awareness SDK package.

4. Update CW with MQX plugin 4.0.x and MQX plugin 4.0.x for ARM.

5. Ran install_cw10.2_plugin.bat "path to Freescale CW installation folder" in cmd.

The problem is that the bat gives some errors regarding the version of the eclipse suite.

Here is the entire log:

 

**** Installing plug-ins for MQX 4.0 ****
Installing com.freescale.mqx.v4.0.feature.group 1.0.1.201211131041.
Installation failed.
Cannot complete the install because one or more required items could not be foun
d.
Software being installed: CodeWarrior MQX 4.0 Plug-ins 1.0.1.201211131041 (com.
freescale.mqx.v4.0.feature.group 1.0.1.201211131041)
Missing requirement: CodeWarrior MQX 4.0 Plug-ins 1.0.1.201211131041 (com.frees
cale.mqx.v4.0.feature.group 1.0.1.201211131041) requires 'org.eclipse.core.runti
me [3.6.0,3.7.0)' but it could not be found
Application failed, log file location: C:\Freescale\CW MCU v10.3\eclipse\configu
ration\1379691608438.log
**** Uninstalling old plug-ins for MQX - all versions ****
Installation failed.
The installable unit com.freescale.mqx.common.feature.group has not been found.
Application failed, log file location: C:\Freescale\CW MCU v10.3\eclipse\configu
ration\1379691612416.log
**** Installing plug-ins for MQX - all versions ****
Installing com.freescale.mqx.common.feature.group 1.1.9.201211131041.
Installation failed.
Cannot complete the install because one or more required items could not be foun
d.
Software being installed: CodeWarrior MQX Plug-ins 1.1.9.201211131041 (com.free
scale.mqx.common.feature.group 1.1.9.201211131041)
Missing requirement: MQX TAD Plug-in 1.1.13.201211131041 (com.freescale.debugge
r.kernel.aware.mqx 1.1.13.201211131041) requires 'bundle org.eclipse.core.runtim
e [3.6.0,3.7.0)' but it could not be found
Cannot satisfy dependency:
  From: CodeWarrior MQX Plug-ins 1.1.9.201211131041 (com.freescale.mqx.common.fe
ature.group 1.1.9.201211131041)
  To: com.freescale.debugger.kernel.aware.mqx [1.1.13.201211131041]
Application failed, log file location: C:\Freescale\CW MCU v10.3\eclipse\configu
ration\1379691614308.log
**** Installing CW10.2 Processor Expert MQX RTOS Adapter update ****
17 File(s) copied
**** Done ****

 

So, what is wrong here?

Thank you very much, in advance.

Outcomes