AnsweredAssumed Answered

K70 "MK70FN1M0VMJ12" Reset pin continuously toggle with sawtooth waveform

Question asked by Prashant Bendre on Sep 20, 2013
Latest reply on Sep 20, 2013 by Prashant Bendre

Hi

We have disigned board with "MK70FN1M0VMJ12". When first time we programmed the board DDR2, NAND flash, UART, DAC & LCD interfaces were woking with test code written.

We are using custom board with K70 microcontroller. Currently we are facing issue with program downloading. We are not able to download any program.

Initially we had downloaded some test code successfully. But later on we are not able to download any code. Please help urgently.

Following are our observations,


  1. 1. We are getting triangular waveform on "RESET PIN".
    2. We are able to detect controller at "Target option--->Debug---->Setting"
    3. When we try to download program we are getting following error message
    "Cannot access memory"

 

We have tried following options to resolve issue,

1.     For ULINK2, debug adapters, Connect and Reset Options in Options For Target — Debug — Settings are set as follows:

-The Connect: option must be set to under Reset

-The Reset: option must be set to HW RESET

 

2.     In our board we are using 12MHz crystal at pin EXTAL1. So we tried programming by disabling crystal.

 

3.     Press the reset button till the programming start.

 

Even after trying above options we are unable to resolve this issue.

Request you to help on priority since we are unable to proceed further testing.

Outcomes