AnsweredAssumed Answered

Slow download for Cyclone Max in CodeWarrior 10.4

Question asked by David Findlay on Sep 19, 2013

I am experiencing an issue with the Cyclone Max(7.76) in CodeWarrior 10.4. I am using a Coldfire MCF5270 for this project. I also have the exact same project running in CodeWarrior 10.2 without this issue.

 

In CodeWarrior 10.2 when I run debug it connects just fine and downloads.

Capture.PNG.png

 

I can see the download progress and it takes about 7 seconds.

 

In CodeWarrior 10.4 when I run debug it also connects just fine but the download looks a bit different and it takes way longer. The progress bar basically jumps right to 100% and then we see "downloading binary to target" where to progress is never indicated. I have to wait about 40 seconds and then it finishes.

 

Capture2.png

The debug configurations are identical. I cannot find any explanation or setting that can account for this difference. I tried a different debugger and both CodeWarrior versions performed like I describe for 10.2. It seems to be a problem just with the Cyclone Max. Has anyone experienced an issue like this? I updated all the drivers and firmware I could. I am running Windows 7 64-bit.

 

Thank you.

Outcomes