John Turnur

Mp4mux is not working

Discussion created by John Turnur on Jul 30, 2013
Latest reply on Aug 31, 2013 by Leonardo Sandoval Gonzalez
Branched from an earlier discussion

Hello 

 

I want to capture the video using parallel camera available on i.MX6Q SDP board and encode it with H.264 encoder and Mp4 as demuxer. I want to store that .mp4 file on SD card.

 

I have tried with following  gst command but it is not working.

 

gst-launch mfw_v4lsrc fps-n=15 capture-mode=4 ! queue ! vpuenc codec=6 ! mp4mux ! filesink location=out.mp4  sync=false

 

I have tried to play .mp4 file on board using below command

 

gst-launch playbin2 uri=file:///out.mp4

 

it does not display anything either on PC or on board.

 

 

SO it looks that Mp4mux is not working.

 

After that i have tried to encode it using matroskamux using below command.

 

gst-launch mfw_v4lsrc fps-n=15 capture-mode=4 ! queue ! vpuenc codec=6 ! matroskamux ! filesink location=output.mkv sync=false

 

and try to play it using play2bin command and it played fine on board but it fails to play on PC using VLC media player.

 

Can anyone help me to get the .mp4 encoding working with mp4mux pipeline?

 

Please help on this issue.

 

Thanks,

J.

Outcomes