AnsweredAssumed Answered

SPI doesn't work on my custom P4080 board

Question asked by Emin Koc on Aug 29, 2013
Latest reply on Sep 3, 2013 by Emin Koc

Hello everyone,

 

I have a custom p4080 board and I haven't got the CodeWarrior TAP yet.

I wanted to try out the board with some different RCW binaries. The RCW source is a 8MB eeprom attached to the SPI. Local bus is not routed out on the board.

I scoped the SPI signals as I powered up the board but there is no logical movement on the SPI signals(MISO, MOSI, CS, CLK all quiet). Something goes wrong so that the RESET_REQ# pin goes low(asserted) and the ASLEEP signal goes logic high(I don't know if this is an assertion or deassertion because I am not sure if this signal is active high or active low,the Reference Manual confused me about this.)

 

I tried both 00100b(16-bit addressing) and 00101b(24-bit addressing) configurations for the SPI interface.

 

I also tried hard-coded RCW it seemed worked. I didn't get a RESET REQUEST. The ASLEEP signal is turned to low. The thing is  I can't get anything on the CLK_OUT signal either way. Is this behavior of the processor normal?

 

Does the ASLEEP signal going low mean a successfully completed reset and system ready state?

 

When I power up the board with a hard-coded RCW the processor draw approximately 4-5Amper more current then when I power up with the SPI as the RCW source. So I assumed that this is because of the PLLs that started by the hard-coded RCW but again I can't see anything on the CLK_OUT pin.

 

Should I concern?

 

What could be the problem of the SPI interface?

 

Thanks in advance

Emin Koç

Outcomes