AnsweredAssumed Answered

eMMC 4.5 support with i.MX28

Question asked by benny chen on Aug 13, 2013
Latest reply on Aug 15, 2013 by jimmychan

Hello,

 

Because eMMC 24nm ver 4.41 EOL.

So our customer wants to move from eMMC 4.41 to eMMC 4.5.

As I know, usually, spec update of iMMC means additional support of new function so compatible to lower version of controller.

So I want to sure eMMC 4.5 can be attached and used as booting device for i.MX28

 

Is there any customer who have tried eMMC 4.5 and who have verified its operation in their board? Below is part info of new eMMC.
Could you comment it?

 

   

old part number

-->

New part number

SANDISK

P/N

SANDISK

SDIN5D2-4G

SANDISK

SDIN7DP2-4G

Technology

24nm

19nm

eMMC ver.

4.4.1

4.5

 

Best Regards,

Benny Chen

 

Outcomes