AnsweredAssumed Answered

K60 TCP/IP Demo

Question asked by Mike Sutton on Aug 12, 2013
Latest reply on Aug 14, 2013 by soledad

I've been struggling today to get any sort of TCP/IP demo working for the TWR-K60D100M + TWR-SER.

 

Here's what I've tried:

 

1) I'm using the special edition of CodeWarrior (maybe that's an issue for some of the demos I've tried??)

2) I started trying to get FreeRTOS working.  There is example code included in KINETIS512_SC.zip that is downloadable from freescale.com.  There is a FreeRTOS example that appears have an http server or some sort of TCIP using either uIP or lwIP.  However, the example isn't a CodeWarrior project, rather a IAR project.  I tried porting it over to CodeWarrior by downloading FreeRTOS and setting up a new project.  I tried both the Freescale compiler and the GCC comiler and couldn't get it to compile all the way with either.

3) After no success with FreeRTOS, I started looking for other options and started trying MQX.  I downloaded MQX and was able to create the vairous projects that form the basis of the RTOS.  However, when I tried to import any of the demos, I can't get them to both compile and run. 

     a) telnet2ser seems like a straightforward example, but has hundreds of compile errors.  I think it might not be referencing the built libraries correctly? 

     b) Several of the examples have #error directives in them that prevent them from compiling because they are apparently deprecated. 

     c) Tried httpsrv in rtsc examples and it gives error: "Overflow in segment: rom from section: .main_application Segment reserved size is: 0x0000fbe0 -- Overflow of: 0x00021dd8"  (Even though I'm using the project specifically for the K60D100M.  Maybe this is the CW special edition size limit?)

 

Kind of seems like I'm going in circles.  If anyone could point me in the right direction of any sort of TCP/IP demo for the TWR-K60D100M + TWR-SER using CodeWarrior, I'd be most appreciative. 

Outcomes