AnsweredAssumed Answered

"mxc_hdmi: No modes read from edid" problem on SABRE iMX6q

Question asked by Stefan Dimitrov on Aug 9, 2013

Hi, i need your help with the board i have "SABRE Board for Smart Devices", Part Numbers: MCIMX6Q-SDB.

 

so, i can boot Linux with using the files from here:

 

i.MX6 Q/D/DL/S L3.0.35_4.0.0 GA release

 

more exactly:

 

* u-boot is: "u-boot-mx6q-sabresd.bin" from L3.0.35_4.0.0_130424_images_MX6.tar.gz

* kernel is: "uImage" from L3.0.35_4.0.0_130424_images_MX6.tar.gz

* rootfs is: rootfs.ext2 from L3.0.35_4.0.0_130424_images_MX6.tar.gz

 

but it seems there is no HDMI output - on dmesg the only relevant messages i can find are:

 

mxc_hdmi mxc_hdmi: Read EDID again

mxc_hdmi mxc_hdmi: No modes read from edid

mxc_hdmi mxc_hdmi: create default modelist

 

so, the only thing from defaults that i changed is the following u-boot settings:

 

bootargs_mmc=setenv bootargs ${bootargs} ip=none root=/dev/mmcblk1p1 rootwait video=mxcfb0:dev=hdmi,1280x720M@60,if=RGB24 video=mxcfb1:off

 

i tried with using "1920x1080M@60" too, but with the exact same result. however, any other device i have with HDMI output works connected to the that same HDMI input that is not working with "SABRE Board for Smart Devices", Part Numbers: MCIMX6Q-SDB. so, what's wrong?

 

thank you,

Stefan

Outcomes