AnsweredAssumed Answered

problem booting image on target from eMMC4.4

Question asked by swl on Aug 10, 2013

I'm trying to download and boot Ubuntu image from eMMC4.4 via HannStar LVDS.

 

I follow the "i.MX_6Dual6Quad_Sabre-SD_Linux_User_Guide.pdf" from L3.0.35_4.0.0_docs using the MFGTool to download image into the sabre board.

 

The cfg.ini file :   

[LIST]

name = ubuntu-SabreSD-eMMC

 

set boot mode as SD3 boot to enter serial download mode for MFGTool

 

did the following command in U-boot prompt

setenv bootargs_mmc 'setenv bootargs ${bootargs} root=/dev/mmcblk0p1 rootwait rw video=mxcfb0:dev=ldb,LDB-XGA,if=RGB666'

setenv bootcmd_mmc 'run bootargs_base bootargs_mmc;mmc dev 3;mmc read ${loadaddr} 0x800 0x2000;bootm'

setenv bootcmd 'run bootcmd_mmc'

saveenv

 

but it hang at the point when I tried to run bootcmd highlighted in red below and subsequently I'm not able to enter U-boot prompt to edit anymore, the only response I get is those that I highlighted in green below.

 

Is there anybody with similar issue or have some idea where should I go about debugging it?

 

 

 

MX6Q SABRESD U-Boot > print

bootdelay=3

baudrate=115200

ipaddr=192.168.1.103

serverip=192.168.1.101

netmask=255.255.255.0

loadaddr=0x10800000

rd_loadaddr=(0x1300000)

netdev=eth0

ethprime=FEC0

uboot=u-boot.bin

kernel=uImage

nfsroot=/opt/eldk/arm

bootargs_base=setenv bootargs console=ttymxc0,115200

bootargs_nfs=setenv bootargs ${bootargs} root=/dev/nfs ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp

bootcmd_net=run bootargs_base bootargs_nfs; tftpboot ${loadaddr} ${kernel}; bootm

stdin=serial

stdout=serial

stderr=serial

ethact=FEC0

bootcmd=run bootcmd_mmc

bootargs_mmc=setenv bootargs ${bootargs} root=/dev/mmcblk0p1 rootwait rw video=mxcfb0:dev=ldb,LDB-XGA,if=RGB666

bootcmd_mmc=run bootargs_base bootargs_mmc;mmc dev 3;mmc read ${loadaddr} 0x800 0x2000;bootm


Environment size: 735/8188 bytes

MX6Q SABRESD U-Boot > saveenv

Saving Environment to MMC...

Writing to MMC(3)... done

MX6Q SABRESD U-Boot > run bootcmd

mmc3(part 0) is current device


MMC read: dev # 3, block # 2048, count 8192 ...


U-Boot 2009.08 (Apr 25 2013 - 01:17:52)


CPU: Freescale i.MX6 family TO1.2 at 792 MHz

Thermal sensor with ratio = 185

Temperature:   45 C, calibration data 0x5954f97d

mx6q pll1: 792MHz

mx6q pll2: 528MHz

mx6q pll3: 480MHz

mx6q pll8: 50MHz

ipg clock     : 66000000Hz

ipg per clock : 66000000Hz

uart clock    : 80000000Hz

cspi clock    : 60000000Hz

ahb clock     : 132000000Hz

axi clock   : 264000000Hz

emi_slow clock: 132000000Hz

ddr clock     : 528000000Hz

usdhc1 clock  : 198000000Hz

usdhc2 clock  : 198000000Hz

usdhc3 clock  : 198000000Hz

usdhc4 clock  : 198000000Hz

nfc clock     : 24000000Hz

Board: i.MX6Q-SABRESD: unknown-board Board: 0x63012 [POR ]

Boot Device: MMC

I2C:   ready

DRAM:   1 GB

MMC:   FSL_USDHC: 0,FSL_USDHC: 1,FSL_USDHC: 2,FSL_USDHC: 3

Original Attachment has been moved to: eMMC4.4-via-HannStar-LVDS-log.txt.zip

Original Attachment has been moved to: eMMC-log.txt.zip

Outcomes