AnsweredAssumed Answered

After configure the clock, how to disable the USB in BSP?

Question asked by Daniel Chai on Aug 6, 2013
Latest reply on Aug 7, 2013 by Daniel Chai

Hi,

 

After I re-configure the clock for my target board, I compile the bsp project. But it gives me error:

"

Errors caused tool to abort.

mingw32-make: *** [Peripheral IO Drivers/usb_dcc/int/usb_dcd_int_kn_c.obj] Error 1

mingw32-make: *** [Peripheral IO Drivers/usb_dcc/polled/usb_dcd_pol_kn_c.obj] Error 1

mingw32-make: *** [Peripheral IO Drivers/usb/usb_mk60f_c.obj] Error 1

 

Errors caused tool to abort.

mingw32-make: *** [Peripheral IO Drivers/usb/usb_install_c.obj] Error 1

mingw32-make: *** [Peripheral IO Drivers/usb_dcc/usb_dcd_mk60_c.obj] Error 1

"

And I checked with freescale engineer, he said the clock frequency I am using is too low to support USB part.(Just 32.768KHz from EXTAL32&XTAL32)

On my target board, I don't want to include the USB part in bsp. How could I do to disable it?

 

Thank you.

 

-Daniel

Outcomes