AnsweredAssumed Answered

Ping is not working from u-boot

Question asked by Raja Sekhar on Jul 17, 2013

Hello to all,

 

 

       I'm working on P2041RDB board and I'm trying PXE boot. for that i configured the u-boot variables ipaddr, ethaddr, netmask, gatewayip, ethact .

 

and i ran the ping command but i'm getting error like as follows..........

 

 

=> ping 192.168.2.144

FM1@DTSEC1: No link.

FM1@DTSEC2: No link.

FM1@DTSEC3: No link.

FM1@DTSEC4: No link.

FM1@DTSEC5: No link.

ping failed; host 192.168.2.144 is not alive

 

 

..........What are the reasons to get that error message.... and this is the total console out put is as follows ...............

 

 

U-Boot 2011.12-00064-gbfb0c9a (Jun 15 2012 - 18:21:35)

 

CPU0:  P2041E, Version: 1.1, (0x82180111)

Core:  E500MC, Version: 2.2, (0x80230022)

Clock Configuration:

       CPU0:1500 MHz, CPU1:1500 MHz, CPU2:1500 MHz, CPU3:1500 MHz,

       CCB:750  MHz,

       DDR:666.667 MHz (1333.333 MT/s data rate) (Asynchronous), LBC:93.750 MHz

       FMAN1: 583.333 MHz

       PME:   375 MHz

L1:    D-cache 32 kB enabled

       I-cache 32 kB enabled

Board: P2041RDB, CPLD version: 4.0 vBank: 0

36-bit Addressing

Reset Configuration Word (RCW):

       00000000: 12600000 00000000 241c0000 00000000

       00000010: 648ea0c1 c3c02000 de800000 40000000

       00000020: 00000000 00000000 00000000 d0030f07

       00000030: 00000000 00000000 00000000 00000000

SERDES Reference Clocks: Bank1=100Mhz Bank2=125Mhz

I2C:   ready

SPI:   ready

DRAM:  Initializing....using SPD

Detected UDIMM UG51U6400N8SU-ACF

2 GiB left unmapped

4 GiB (DDR3, 64-bit, CL=9, ECC off)

       DDR Chip-Select Interleaving Mode: CS0+CS1

Testing 0x00000000 - 0x7fffffff

Testing 0x80000000 - 0xffffffff

Remap DDR 2 GiB left unmapped

 

POST memory PASSED

Flash: 128 MiB

L2:    128 KB enabled

Corenet Platform Cache: 1024 KB enabled

SERDES: bank 3 disabled

SRIO1: disabled

SRIO2: disabled

MMC:  FSL_SDHC: 0

EEPROM: Invalid ID (ff ff ff ff)

PCIe1: disabled

PCIe2: Root Complex, no link, regs @ 0xfe201000

PCIe2: Bus 00 - 00

PCIe3: disabled

In:    serial

Out:   serial

Err:   serial

Net:   Initializing Fman

Fman1: Uploading microcode version 106.1.4

FM1@DTSEC1, FM1@DTSEC2, FM1@DTSEC3, FM1@DTSEC4, FM1@DTSEC5

Hit any key to stop autoboot:  0

=>

=> pri ipaddr

ipaddr=192.168.2.168

=> pri etha  

  ethact ethaddr

=> pri ethaddr

ethaddr=00-04-9F-02-4C-4C

=> printenv netmask

netmask=255.255.255.0

=> printenv gatewayip

gatewayip=192.168.2.123

=> printenv ethact   

ethact=FM1@DTSEC1

=> ping 192.168.2.144

FM1@DTSEC1: No link.

FM1@DTSEC2: No link.

FM1@DTSEC3: No link.

FM1@DTSEC4: No link.

FM1@DTSEC5: No link.

ping failed; host 192.168.2.144 is not alive

=>

 



 


Original Attachment has been moved to: ping_issue.log.zip

Outcomes