AnsweredAssumed Answered

jb4.2.2_1.1.0-ga ; c_patch ; Error! Fail to apply patch

Question asked by jeromeolivier on Jul 17, 2013
Latest reply on Oct 16, 2013 by jun kong
Branched to a new discussion

Hello everyone,

 

I downloaded yesterday the android-4.2.2_r1 branch of the google source and I tried to apply the jb4.2.2_1.1.0-ga release patches :

$ cd ~/aosp/fsl-jb-1.1.0

$ repo init -u https://android.googlesource.com/platform/manifest -b android-4.2.2_r1

$ c_patch ~/aosp/android_jb4.2.2_1.1.0-ga_source/code/jb4.2.2_1.1.0-ga imx_jb4.2.2_1.1.0-ga
[...]

Switching base version for system/security
Applying patches ...
Applying patch to external/linux-lib
unable to parse patch level, ignoring it.
trailing garbage found in series file: olivier dev 1.6M Jun 20 22:37 0001-Initial-commit-from-CVS.patch
Error! Fail to apply patch from /home/olivier/aosp/android_jb4.2.2_1.1.0-ga_source/code/jb4.2.2_1.1.0-ga/platform/external/linux-lib.git to /home/olivier/aosp/fsl-jb-1.1.0/external/linux-lib. Stop

 

Do you know what could be the origin of this error ? I changed a little bit c_patch to get the error log output from the patching line:

line 514 :git quiltimport --patches ${patch_git_dirs[$x]} #> /dev/null

 

 

Outcomes