AnsweredAssumed Answered

u-boot can't boot from eMMc4.4

Question asked by zhu haigang on Jun 28, 2013
Latest reply on Sep 18, 2013 by Yuri Muhin
Branched to a new discussion

I buy the Freescale i.MX53 Quick Start board. it's mx53_loco.

I download i.MX53-QSB-Android-Gingerbread-Release4.3 from Reference BSPs for Freescale i.MX53 Quick Start Board.

copy all file of prebulid floder to ..\Profiles\MX53 Linux Update\OS Firmware\files\android\.(Mfgtools tools)

Then open Mfgtools tools,select mx53_smd_android_emmc4.4.   Start ,operation Success.

u-boot can't boot from emmc4.4.

I suspect \Profiles\MX53 Linux Update\OS Firmware\files\ucl.xml is error.so I see it.

ucl.xml :

Please use slot3 for MMC4.4 update

      The following are the valid inputs when configure the boot

      partitions of the eMMC cards.

      +------------------------------------------------------------+

      | Bit7 | Bit6     | Bit5 Bit4 Bit3        | Bit2 Bit1 Bit0   |

      |------|----------|-----------------------|------------------|

      | X    | BOOT_ACK | BOOT_PARTITION_ENABLE | PARTITION_ACCESS |

      +------------------------------------------------------------+

      Bit7: Reserved

      Bit6: always set to vaule '1' when boot_part is enabled

      Bit[5:3]:

      0x0 : Device not boot enabled (default)

      0x1 : Boot partition 1 enabled for boot

      0x2 : Boot partition 2 enabled for boot

      0x7 : User area enabled for boot

      Bit[2:0]:

      0x0 : No access to boot partition (default)

      0x1 : R/W boot partition 1

      0x2 : R/W boot partition 2

      So only the '0, 1, 2; 8, 9, 10; 16, 17, 18; 56, 57, 58' are

      valid parameters when configure the boot_partiton.

 

<CMD type="push" body="$ echo 1 > /sys/devices/platform/mxsdhci.2/mmc_host/mmc2/mmc2:0001/boot_config">access boot partition 1</CMD>

<CMD type="push" body="$ echo 8 > /sys/devices/platform/mxsdhci.2/mmc_host/mmc2/mmc2:0001/boot_config">access user partition,and enable boot partion1 to boot</CMD>

<CMD type="push" body="$ echo 2 > /sys/devices/platform/mxsdhci.2/mmc_host/mmc2/mmc2:0001/boot_bus_config">Set boot width is 8bits</CMD>


Red color of the sentences I do not know what that means?

by the way,I test successful u-boot boot from eMMc4.4 by the same u-boot.bin,but not use Mfgtools.Steps are as follows

eMMC 4.3 and 4.4 card support fastboot. To boot from fastboot, please follow below steps:

1. Make sure the slot can support fastboot.

Please check spec for this information. On most of our boards, Slot3 support eMMC fastboot.

2. Program u-boot image to eMMC boot partition.

Normal boot from SD first and program u-boot image to boot partition.

e.g

• Insert normal SD card to slot1 and eMMC 4.3/4.4 card to slot3.

• Normal boot from SD slot1.

• Write u-boot.bin to eMMC card boot partition.

e.g

> mmc read 0 ${loadaddr} 0 0x200

MMC read: dev # 0, block # 0,count 512 ...

512 blocks read: OK

> mmc write 1 ${loadaddr} 0 0x200 1

MMC read: dev # 1, block # 0,count 512 ... partition 1

512 blocks write: OK

3. Get eMMC bus width.

Get boot bit bus mode. Use command “mmcinfo <dev>“ to get bus width.

> mmcinfo 1

Device: FSL_ESDHC

Manufacturer ID: 3

OEM: 5344

Name: SD04G

Tran Speed: 25000000

Rd Block Len: 512

SD version 2.0

High Capacity: Yes

Capacity: 3965190144

Bus Width: 4-bit

4. Set eMMC fast boot dip and boot bits.

• Set eMMC fast boot dip.

• Set bus width to the bus width we got from step 3.

5. Reset board for booting.

 

why u-boot can't boot from eMMc4.4 by Mfgtools?I just say ..


can anybody help me?

Outcomes