AnsweredAssumed Answered

Ubuntu RFS problem on imx6

Question asked by Mark Twain Jr on Jun 17, 2013

Hello All,

 

I am using ubuntu_oneiric_4.0.0.tgz as ubuntu RFS to boot it using on IMX6 board using mfgtool to prepare sd card, i am getting uboot prompt where i set following bootargs to display on hdmi monitor

 

setenv bootargs_mmc 'setenv bootargs ${bootargs} root=/dev/mmcblk1p1 rootwait rw init=/init video=mxcfb0:dev=hdmi,1920x1080M@60,if=RGB24 video=mxcfb1:off video=mxcfb2:off '

setenv bootcmd_mmc 'run bootargs_base bootargs_mmc;mmc dev 2;mmc read ${loadaddr} 0x800 0x2000;bootm'

setenv bootcmd 'run bootcmd_mmc'

saveenv

run bootcmd

 

Please see attached complete log

 

But i could not see anything on display..What am i missing here or doing incorrect?

 

it seems that Xorg/X11 servers are running already, What do i need to look further if i want to run OpenGL demo on ubuntu RFS.? Please see attached txt file for complete logs.

 

Further i tried to follow instructions in "Instructions_to_setup_X11_acceleration_on_Ubuntu.txt" in order to run GPU/OpenGL demos but due to network interface problem i am unable to download packages using apt-get and dpkg also !!.... How to i enable network support to imx6 board having above RFS?

ifconfig shows following

linaro@linaro-ubuntu-desktop:/$ ifconfig

lo        Link encap:Local Loopback 

          inet addr:127.0.0.1  Mask:255.0.0.0

          UP LOOPBACK RUNNING  MTU:16436  Metric:1

          RX packets:128 errors:0 dropped:0 overruns:0 frame:0

          TX packets:128 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:0

          RX bytes:9728 (9.7 KB)  TX bytes:9728 (9.7 KB)

 

I;ve also tried

linaro@linaro-ubuntu-desktop:/$ sudo ifconfig eth0 192.168.0.200 up

SIOCSIFADDR: No such device

eth0: ERROR while getting interface flags: No such device

eth0: ERROR while getting interface flags: No such device

 

 

 

??

 

So any help would be really appriciated.

 

Thanks,

MT

Original Attachment has been moved to: ubuntu-kernel-boot.txt.zip

Original Attachment has been moved to: ubuntu-Xorg_log.txt.zip

Outcomes