AnsweredAssumed Answered

CodeWarrior 10.x Rebuild problems

Question asked by yanam on Jun 13, 2013
Latest reply on Jun 14, 2013 by Pascal Irrle

Hello All,

 

 

Has anyone come across Build problems in Eclipse based CodeWarrior 10.x. This has been seen for Kinetis CW 10.4 Evaluation Version.

 

 

1. . A macro was defined as

 

 

#define PRINT_ARG(x) printf(x) 

 

 

which was removed later i.e..

 

 

#define PRINT_ARG(x) 

 

 

Even after ‘Clean-Build’ and ‘Re-build’ the tool-tip against that micro used to display the same function; and also the executable had that debug prints. After changing PRINT_ARG(x) to wrong function i.e.

 

 

#define PRINT_ARG(x) sdsdsdsd

 

 

it showed up compilation error and then going back to removing the printf(x) worked, the tool-tip too cleared up that old macro.

 

 

2. A two dimensional array was allocated at address well inside the range of our microcontroller. The LCF was used was of Tower Board K60x512… however I was unable to change the values in the array. Previous to this all other memory variables worked fine on my target microcontroller. After encountering this problem I found my mistake and replaced the LCF file, which worked thereafter...

 

 

3. I was creating an example project for Freescale employee to try and reproduce above problems removing lot of confidential part from the code. This also removed some definition of macros, functions and extern variables that were used in the example main.c. However, at first it compiled, downloaded and ran successfully with debugger. It did second time as well, however the third time it gave me plethora of errors claiming missing definitions, which was obviously expected the first time. I handled it and it worked fine...

 

Please share your experiences and if there is any setting that can help, please let me know.

 

 

Regards,

Yogendra

 

Outcomes