AnsweredAssumed Answered

Using two parallel TV decoders connected to two CSI ports on IMX6Q

Question asked by Kamil Lulko on Jun 7, 2013
Latest reply on Apr 3, 2015 by Angelo Aresi

Hello,

 

We are trying to use two TVP5150 decoders on our custom board connected to CSI0-IPU0 and CSI1-IPU1 respectively. Source signal for both decoders comes from two PAL cameras. The CSI0-IPU0 works good, tested with tvin and overlay unit tests (though I had to manually set input height to 576 to get proper vsync in overlay test). Below is a screenshot from running overlay unit test on CSI0-IPU0 path from first TVP5150:

cam1.png

As you can see the image is ok, apart from some horizontal and vertical blank pixels .

 

Using the same driver we tried to test CSI1-IPU1 path, and this is the result:

cam2.png

The capture is both not hsynced and vsynced (scrolling in both axes). There are also some green and purple lines showing up. To be sure that secondary TVP5150 output signal is correct we disabled first decoder chip from CSI0-IPU0 path and connected digital outputs from CSI1-IPU1 path decoder to CSI0-IPU0 inputs and image was OK (like on first screenshot). Since we are using BT.656 mode in decoder/mxc_v4l2_capture we can assume pins are muxed correctly (since IPU detects EAV nad SAV properly). This leads me to believe problem must be on mxc_v4l2_capture or IPU driver side.

 

Documentation shows only CSI0-IPU0 and CSI-MIPI examples, also searching here gave no reports of working CSI1-IPU1 parallel cameras/tv decoders. There was one attempt to have working double tvp5150 on imx53 but that chip has only one IPU and does not support two simultaneous cameras running. According to sources I gathered the imx6q should be able to handle two simultaneous parallel CSI cameras since it has two IPUs.

 

We are basing our code on 1.1.0 BSP but I backported IPU and v4l changes from 4.0.0 release to our codebase and still same result. Did anyone get dual parallel CSI cameras/tv decoders working on IPU0 and IPU1? Any help would be great and useful to the community since apparently I am not the only one having problems with CSI1+IPU1.

Outcomes