AnsweredAssumed Answered

imx6 jb4.2.2_1.0.0-ga boot problem

Question asked by thomasbn on Jun 4, 2013
Branched to a new discussion

Hi,

 

I'm trying to run the new android release on a imx6 sabreSD board.

I'm using the release from here: https://community.freescale.com/docs/DOC-94798

 

I have tried several ways:

  - The prebuilt from freescale for the SDcard.

  - The prebuilt from freescale for the NFS.

  - Build the AOSP and boot the result via NFS.

 

For all of them, I'm always stuck at the boot animation.

 

It seems there are some problems related to the android framework, but I don't really understand them.

I attached two logcat files, one for the sdcard case and another for the nfs case (both from prebuilt).

After theses errors/failures, all the services are restarted and the same errors show up again.

The following logcat command have been used:  logcat *:E

 

If it can help, I followed the "User_Guide" documentation and my uboot environment is something like:

 

SD:

setenv bootcmd booti mmc2

setenv bootargs console=ttymxc0,115200 init=/init video=mxcfb0:dev=ldb,bpp=32 video=mxcfb1:off video=mxcfb2:off fbmem=10M fb0base=0x27b00000 vmalloc=400M androidboot.console=ttymxc0 androidboot.hardware=freescale

 

NFS:

setenv serverip 192.168.16.25

setenv bootfile uImage-android-jb

setenv nfsroot /opt/rootfs/imx6jb-pre

setenv bootcmd 'dhcp;bootm'

setenv bootargs console=ttymxc0,115200 init=/init ip=dhcp nfsroot=${serverip}:${nfsroot} video=mxcfb0:dev=ldb,bpp=32 video=mxcfb1:off video=mxcfb2:off fbmem=10M fb0base=0x27b00000 vmalloc=400M androidboot.console=ttymxc0 androidboot.hardware=freescale

 

Thanks for your help,

Kind regards.


Original Attachment has been moved to: logcat.nfs.zip

Original Attachment has been moved to: logcat.sdcard.zip

Outcomes