AnsweredAssumed Answered

Ltib fails with BSP4

Question asked by AlbertT on Jun 3, 2013
Latest reply on Jun 4, 2013 by AlbertT

Hello !

 

I can't finish a proper build with the new BSP. I am working on Ubuntu 12.04 and applied the same modifications that I did for previous BSP. But now this is not anymore about path to libraries and so on but more on the encoding I guess.

 

When Ltib tries to build u-boot, it fails with :

Applying ENGR00081147 Support i.MX35 3stack board

*

* You have some suspicious patch lines:

*

* In board/freescale/mx35_3stack/lowlevel_init.S

* indent SP followed by a TAB (line 381)

board/freescale/mx35_3stack/lowlevel_init.S:381:           mov r3, #0xDA

* indent SP followed by a TAB (line 400)

board/freescale/mx35_3stack/lowlevel_init.S:400:           str r3, [r1, #0x100]

+ exit 0

 

Try u-boot-2012.10.tar.bz2.md5 from the GPP

http://bitshrine.org/gpp/u-boot-2012.10.tar.bz2.md5:

14:32:49 ERROR 404: Not Found.

Try u-boot-2012.10.tar.bz2 from the GPP

http://bitshrine.org/gpp/u-boot-2012.10.tar.bz2:

14:32:49 ERROR 404: Not Found.

Can't get: u-boot-2012.10.tar.bz2 at ./ltib line 802.

 


I removed this patch and it worked, but then I have an other error with the kernel and LTIB stills complain about trailing whitespace so I guess I am missing something. Does anyone has experienced this already ?


PS : I tried to build u-boot 2012 but I have this :



Thanks !

Outcomes