AnsweredAssumed Answered

Android 4.2.2_r1 Patch and Compilation Issue

Question asked by Santosh Kadam on May 16, 2013
Latest reply on May 27, 2013 by Yixing Kong
Branched to a new discussion

Hi there,

 

I am following the steps to patch the AOSP4.2.2_r1 source with the patches downloaded from the freescale link. I am facing problems in compiling the patched code and getting the following errors.

 

target arm C: libmusicbundle <= frameworks/av/media/libeffects/lvm/lib/Common/src/MSTo2i_Sat_16x16.c

make[1]: Entering directory `/home/san/android/hardware/imx/wlan/atheros/compat-wireless'

/home/san/android/hardware/imx/wlan/atheros/compat-wireless/config.mk:49: *** "ERROR: your kernel has CONFIG_CFG80211=y, you should have it CONFIG_CFG80211=m if you want to use this thing.".  Stop.

 

 

I have verified in my kernel directory for the value "CONFIG_CFG80211=y" and set it to "CONFIG_CFG80211=m". Even after making these changes, I am still facing this error.

 

Can you please provide any help in resolving the same ?

 

thanks and warm regards

santosh

 

 


Outcomes