AnsweredAssumed Answered

Latest uboot source missing sabre board and config files

Question asked by Sriram Chadalavada on May 15, 2013
Latest reply on Oct 13, 2013 by koby hershkovitz
Branched to a new discussion

I followed the instructions in the Freescale Android Users Guide Rev jb4.2.2_1.0.0-GA to pull latest uboot source.

 

However, when I tried building it, it failed.

 

ram@ram-Latitude-E6520:~/Prevas/Android_porting/Freescale/imx6/4.2.2/myandroid/bootable/bootloader/uboot-imx$ make mx6q_sabresd_android_config

awk '(NF && $1 !~ /^#/) { print $1 ": " $1 "_config; $(MAKE)" }' boards.cfg > .boards.depend

make: *** No rule to make target `mx6q_sabresd_android_config'.  Stop.

make: *** [mx6q_sabresd_android_config] Error 1

 

When I compared this version of uboot source with the uboot source I pulled with 4.0.4 Freescale release, I found these files missing:


./board/freescale/mx6q_sabrelite

./board/freescale/mx6q_sabrelite/mx6q_sabrelite.c

./board/freescale/mx6q_sabrelite/lowlevel_init.S

./board/freescale/mx6q_sabrelite/config.mk

./board/freescale/mx6q_sabrelite/u-boot.lds

./board/freescale/mx6q_sabrelite/Makefile

./board/freescale/mx6q_sabrelite/flash_header.S

./board/freescale/mx6q_sabresd

./board/freescale/mx6q_sabresd/libmx6q_sabresd.a

./board/freescale/mx6q_sabresd/lowlevel_init.S

./board/freescale/mx6q_sabresd/mx6q_sabresd.c

./board/freescale/mx6q_sabresd/config.mk

./board/freescale/mx6q_sabresd/u-boot.lds

./board/freescale/mx6q_sabresd/.depend

./board/freescale/mx6q_sabresd/Makefile

./board/freescale/mx6q_sabresd/flash_header.S

./board/freescale/mx6q_sabreauto

./board/freescale/mx6q_sabreauto/lowlevel_init.S

./board/freescale/mx6q_sabreauto/mx6q_sabreauto.c

./board/freescale/mx6q_sabreauto/config.mk

./board/freescale/mx6q_sabreauto/u-boot.lds

./board/freescale/mx6q_sabreauto/Makefile

./board/freescale/mx6q_sabreauto/flash_header.S

./include/configs/mx6solo_sabreauto_weimnor_mfg.h

./include/configs/mx6q_sabresd_iram.h

./include/configs/mx6dl_sabreauto_mfg.h

./include/configs/mx6dl_sabresd_android.h

./include/configs/mx6solo_sabreauto.h

./include/configs/mx6solo_sabreauto_mfg.h

./include/configs/mx6dl_sabreauto_spi-nor.h

./include/configs/mx6solo_sabresd_android.h

./include/configs/mx6q_sabresd_android.h

./include/configs/mx6q_sabreauto_spi-nor_mfg.h

./include/configs/mx6q_sabrelite_mfg.h

./include/configs/mx6q_sabreauto_nand_mfg.h

./include/configs/mx6q_sabreauto_mfg.h

./include/configs/mx6dl_sabreauto_weimnor.h

./include/configs/mx6q_sabreauto_weimnor.h

./include/configs/mx6solo_sabreauto_nand_mfg.h

./include/configs/mx6q_sabrelite.h

./include/configs/mx6solo_sabresd.h

./include/configs/mx6solo_sabreauto_spi-nor_mfg.h

./include/configs/mx6dl_sabreauto_nand_mfg.h

./include/configs/mx6dl_sabreauto_spi-nor_mfg.h

./include/configs/mx6dl_sabresd.h

./include/configs/mx6q_sabresd_mfg.h

./include/configs/mx6solo_sabreauto_spi-nor.h

./include/configs/mx6q_sabreauto_nand.h

./include/configs/mx6dl_sabreauto_nand.h

./include/configs/mx6dl_sabresd_mfg.h

./include/configs/mx6dl_sabreauto_weimnor_mfg.h

./include/configs/mx6q_sabresd.h

./include/configs/mx6dl_sabreauto.h

./include/configs/mx6q_sabreauto_spi-nor.h

./include/configs/mx6q_sabreauto_weimnor_mfg.h

./include/configs/mx6solo_sabreauto_nand.h

./include/configs/mx6q_sabreauto.h

./include/configs/mx6q_sabrelite_android.h

./include/configs/mx6solo_sabreauto_weimnor.h

 

Is this something broken on the jb4.2.2_1.0.0-ga branch? If so, how do I ask or notify the code maintainers?


Thanks


Outcomes