Robert Braisted

Linker error undefined "__sinit__" when converting project from CW 6.3 to 7.2

Discussion created by Robert Braisted on May 2, 2013
Latest reply on Jan 24, 2014 by Cristina Casas

I'm trying to migrate to a newer version of the CodeWarrior compiler for ColdFire processors. I had a project that successfully built and linked in the old version. (the good ole days), but fails with the newer version. I saw some messages related to removing obsolete libs during the conversion that i suspect might be related to the problem. Here are some more details:

 

old => CodeWarrior® Development Studio for ColdFire Architectures Version 6.3, Build 14

          IDE Version: 5.7.0 Build 2015

 

new => CodeWarrior Development Studio for ColdFire Architectures Version 7.2, Build 91218.

          IDE Version: 5.9.0 Build 5293

 

when you open the existing .mcp file, CodeWarrior automatically converts to the newer version because of differences in preference panel data between the versions among other things. When i try to build this same project after the auto-conversion happens i get the following linker error.

 

Link Error : Undefined : "__sinit__"

Referenced from "__call_static_initializers" in

Outcomes