AnsweredAssumed Answered

Bootloader Problem on kenetis k53

Question asked by wilson garil on Apr 30, 2013
Latest reply on May 15, 2013 by wilson garil

Hi Guys,

Im trying to implement the bootloader  on my custom board with the Kenetis K53 MCU using MQX

im facing the the following problem :  ""No source available for "0xFFFFFFFE (0xFFFFFFFE)() "" this is due to the change in the linker file.

 

SO IM NOT ABLE TO DEBUG MY BOOTLOADER APP

 

basically im just following the AN4370 document which explain stuff related to the bootloader and so on, im still in the first step i cannot event debug my

bootloader application due to the error above.

 

can someone please tell me where is the error in the below linker file, or why the above error occur?

 

WORKING

vectorrom   (RX): ORIGIN = 0x00000000, LENGTH = 0x00000400    cfmprotrom  (RX): ORIGIN = 0x00000400, LENGTH = 0x00000010    rom         (RX): ORIGIN = 0x00000420, LENGTH = 0x0007FBE0  # Code + Const data      ram         (RW): ORIGIN = 0x1FFF0000, LENGTH = 0x00020000  # SRAM - RW data

 

NOT WORKING

vectorrom   (RX): ORIGIN = 0x0000A000, LENGTH = 0x00000400    cfmprotrom  (RX): ORIGIN = 0x0000A400, LENGTH = 0x00000010    rom         (RX): ORIGIN = 0x0000A420, LENGTH = 0x00075BE0  # Code + Const data      ram         (RW): ORIGIN = 0x1FFF0000, LENGTH = 0x00020000  # SRAM - RW data

 

beside these changes, i set the rom vector to 0 basically in the config file i have

#define MQX_ROM_VECTORS      0

 

there are some other change to do, do i  have a mistake in the changes above, can someone make me understand how to change the linker file correctly?

 

 

thx in advance,

BR

 

Wilson

Outcomes