AnsweredAssumed Answered

about mxc_vpu_test on imx6q linux

Question asked by andypeng on Apr 24, 2013
Latest reply on Apr 29, 2013 by Leonardo Sandoval Gonzalez
Branched to a new discussion

Hi all,

  I tried to test mxc_vpu_test.out for Network-encode camera captured YUV data and send it to another side to decode by UDP on imx6q,by follow command:

./mxc_vpu_test.out -E "-n 192.168.3.11 -p 2011 -w 320 -h 240 -f 2 -t 1"

debug information:

[INFO]  VPU test program built on Apr 24 2013 09:46:56                          

[INFO]  Product Info: i.MX6Q/D/S                          

[INFO]  VPU firmware version: 2.1.8_r34588                

[INFO]  VPU library version: 5.4.10                       

[INFO]  Format: STD_AVC                                   

[INFO]  AVC                                               

[INFO]  encoder sending on port 2011                      

[INFO]  chromaInterleave 1, mapType 0, linear2TiledEnable 0

[INFO]  sensor chip is ov5642_camera                      

[INFO]  sensor frame size is 320x240

 

on the PC I used vlc media player,but I got No screen display.I tried follow command :

gst-launch -vvv --gst-debug=3 udpsrc port=2011 \

caps ="video/x-h264, width=(int)320, height=(int)240, framerate=(fraction)25/1, framed=(boolean)true" \

! ffdec_h264 \

! ffmpegcolorspace \

! videoscale \

! xvimagesink sync=false

 

the vedio is not right too.

How could i do with use the mxc_vpu_test for H264 test?

and who could send me a h264 player?

 

Can anybody answer this question?

Outcomes