AnsweredAssumed Answered

MCIMX6Q-SDB Linux, nfs not working

Question asked by ambiguity on Apr 12, 2013
Latest reply on Apr 12, 2013 by ambiguity

Hi,

 

I am having an issue getting the MCIMX6Q-SDB up and running with Linux (L3.0.35 untouched).  My goal is to get it up and running before making modifications.  I am trying to get it to run over NFS.  I have thumbed through as many forums over the past couple of days and it is still not working.  It is able to find the image and start, but when it starts performing root operations (my suspicion) they are getting denied and nothing after.

 

Does anyone know how to resolve this?

 

Here is the log:

File transfer via NFS from server 192.168.2.101; our IP address is 192.168.2.100
Filename '/home/user/rootfs_imx6/boot/uImage'.
Load address: 0x10800000
Loading: #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         #################################################################
         ####################################################
done
Bytes transferred = 3922500 (3bda44 hex)
## Booting kernel from Legacy Image at 10800000 ...
   Image Name:   Linux-3.0.35-2310-gc27cb38
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    3922436 Bytes =  3.7 MB
   Load Address: 10008000
   Entry Point:  10008000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK
OK

Starting kernel ...

Uncompressing Linux... done, booting the kernel.
Linux version 3.0.35-2310-gc27cb38 (removed) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #4 SMP PREEMPT Fri Apr 12 18:04:01 CEST 2013
CPU: ARMv7 Processor [412fc09a] revision 10 (ARMv7), cr=10c53c7d
CPU: VIPT nonaliasing data cache, VIPT aliasing instruction cache
Machine: Freescale i.MX 6Quad/DualLite/Solo Sabre-SD Board

 

..

..

..

Sending DHCP requests ., OK

IP-Config: Got DHCP answer from 192.168.2.1, my address is 192.168.2.100

IP-Config: Complete:

     device=eth0, addr=192.168.2.100, mask=255.255.255.0, gw=192.168.2.1,

     host=192.168.2.100, domain=, nis-domain=(none),

     bootserver=192.168.2.1, rootserver=192.168.2.101, rootpath=

VFS: Mounted root (nfs filesystem) on device 0:12.

Freeing init memory: 208K

starting pid 1423, tty '': '/etc/rc.d/rcS'

Mounting /proc and /sys

mount: permission denied (are you root?)

mount: permission denied (are you root?)

/etc/rc.d/init.d/udev: line 11: /proc/sys/kernel/hotplug: No such file or directory

mount: permission denied (are you root?)

mknod: /dev/console: Operation not permitted

mknod: /dev/null: File exists

Starting the hotplug events dispatcher udevd

Synthesizing initial hotplug events

mkdir: can't create directory '/dev/pts': File exists

mount: permission denied (are you root?)

mkdir: can't create directory '/dev/shm': File exists

Setting the hostname to freescale

hostname: sethostname: Operation not permitted

Mounting filesystems

mount: permission denied (are you root?)

mount: permission denied (are you root?)

mount: permission denied (are you root?)

cat: can't open '/proc/cmdline': No such file or directory

ln: /etc/mtab: File exists

mount: permission denied (are you root?)

chown: /home/user/.rhosts: Operation not permitted

chown: /home/user: Operation not permitted

chown: /home/user: Operation not permitted

cat: can't open '/proc/devices': No such file or directory

starting pid 1463, tty '': '/etc/rc.d/rc_gpu.S'

cat: can't open '/proc/cpuinfo': No such file or directory

starting pid 1469, tty '': '/etc/rc.d/rc_mxc.S'

 

 

I believe the share/export on the VM is setup correctly.  It is setup exactly the same way the prev. project (i.mx35) is setup.

 

A little more background... I compiled the source using LTIB (Ubuntu 9.04) and copied the output rootfs to another Ubuntu VM (12.04) (since this contained all our necessary software/ tools).

 

Lastly, I am kind of new to this... I am expecting there to be a "serial console" so I can query directories and what not... is this by default?  Seial console was selected in the menuconfig.

 

Any ideas?

 

Thanks!

Outcomes