AnsweredAssumed Answered

Garbage on the MX51 uart

Question asked by Allen Kennedy on Apr 11, 2013
Latest reply on Apr 26, 2013 by Allen Kennedy
Branched to a new discussion

Hello,

  I have search and seen this topic brought up before, but have seen no solutions.

I am having trouble with the mxc_uart.c driver for linux.  u-Boot initializes the

uart properly, and the kernel's mxc_uart_early.c driver works fine, but when the console

is switched from the early driver to the "main" driver, the serial port just starts spitting out garbage.  Usually in the form of FF, but sometimes FE, ans sometimes just other junk.

 

if I hold down the 'a' key, I will see 0x61 come back some of the time, but usually it's some garbage.

 

I've tried the "change the kernel to use pll3 instead of pll2" trick to no avail.  I have tried putting printK's to see what's going on, but as soon as the peripheral is reset in the driver code, I lose print ability, understandably.

 

I have checked the output on a oscilliscope.  The timing seems to be correct for the garbage data that is coming out.

 

Where do I go from here?  I don't have JTAG, so I can't debug in that way.  I'm sort of at a loss.

 

ideas?

 

thanks,

-Allen

Outcomes