AnsweredAssumed Answered

SRecCvt-Gui won't run

Question asked by Gilbert Gagne on Apr 2, 2013
Latest reply on Apr 24, 2013 by Gilbert Gagne

Since a recent WIN7 update my PC won't run SRecCvt-Gui converting .S19 files for download to Flash on a MC9S12DP512.

It yields a message, "Improper Format in 'DeviceInfo.Dat' file". I tried downloading a new version of SREC to no avail.

I even uninstalled all the recent WIN7 updates and the same message comes back. I've experienced a similar problem in the

past and uninstalling updates solved the problem, but not this time.

 

 

In an attempt to circumvent this problem I tried running the DOS version SRecCvt.exe with the following command line:

sreccvt.exe -s2 -b 32 0x20 32 -lp -o c:\miniide\out.s19 c:\miniide\main.s19 which produces an output file whose 1st

line is: S224008000164649CE096616627916604ACE0A9D16627916623216466CCE096A166279166048.

 

 

For the same input file SRecCvt-Gui used to produce a slightly different output file with the following 1st line:

S224080000164649CE096616627916604ACE0A9D16627916623216466CCE096A1662791660C0

 

 

Except for the S2 addresses and the checksums, the lines are identical. My question is why are they not identical ?

And does it make any difference ?

 

Outcomes