AnsweredAssumed Answered

LTIB build problem at package pkgconfig for Freescale M54418

Question asked by Francois Bouchard on Mar 22, 2013
Latest reply on Mar 25, 2013 by Francois Bouchard

Hi,

Ltib build is failing at package pkgconfig,

 

MESSAGE:

(...)

checking for a BSD-compatible install... /usr/bin/install -c

checking for extra flags to get ANSI library prototypes... configure: error: cannot run test program while cross compiling

See `config.log' for more details.

configure: error: /bin/bash './configure' failed for glib-1.2.8

error: Bad exit status from /home/fbouchard/ltib/ltib-modelo-20100709/tmp/rpm-tmp.91454 (%build)

 

 

RPM build errors:

    Bad exit status from /home/fbouchard/ltib/ltib-modelo-20100709/tmp/rpm-tmp.91454 (%build)

Build time for pkgconfig: 14 seconds

 

Failed building pkgconfig

 

 

f_buildrpms() returned an error, exiting

traceback:

main:560

 

 

Started: Fri Mar 22 16:58:16 2013

Ended:   Fri Mar 22 16:59:16 2013

Elapsed: 60 seconds

 

These packages failed to build:

pkgconfig

 

Build Failed

 

Exiting on error or interrupt

 


 

Now in a post I saw if I understand correctly, this package isn't meant for the Coldfire processors

--> http://comments.gmane.org/gmane.comp.package-management.pkg-config/342

Hi,

 

Enrico> The bundled glib-1.2.10 is not crosscompile'able.

 

Enrico> Look at glib-1.2.10/configure.ac: once you use AC_TRY_RUN, your

Enrico> package cannot crosscompile. A very common standard error in

Enrico> autoconf-based packages ...

 

But if you build with an external libglib (--with-installed-glib) it

builds without problems.

 

- tried in pkconfig.spec (made backup of the original)

 

 

I tried the trick above but it didn't work.

 

 

Any hints on how to compile pkgconfig?

 

Francois

 


Outcomes