AnsweredAssumed Answered

Classic codewarrior 7.1.1, Windows 7 64-bit, and PEMICRO debugger are not compatible

Question asked by mikegr on Mar 22, 2013
Latest reply on Apr 11, 2013 by mikegr


I am recently responsible for maintaining a codebase with a coldfire V2 target (MCF52277) that includes MQX RTOS 3.0.1.  This codebase will compile under codewarrior 7.1.1.  I would like to use the existing tool chain (codewarrior 7.1.1 and PEmicro Coldfire Multilink debugger, USB-ML-CFE) to compile, debug, and build the firmware.  I have a Windows 7 64-bit machine and have been unsuccessful at using the PEmicro debugger with Codewarrior.  I tried the following two methods and both failed.  Do you have any suggestions?


Method #1

I followed the freescale recommended procedure to install classic codewarrior 7.1.1 on a 64 bit machine (see instructions here ).  I installed Windows Virtual PC and Windows XP mode.  I installed codewarrior 7.1 in the windows XP virtual machine.  This allowed me to compile my code.  I plug in the pemicro debugger to the USB port and my Windows 7 device found it (latest pemicro drivers were installed).  However, when I try to attach in XP mode, it will not attach the USB device.   I most cases when I try to attached on several USB ports, it will not attach to the virtual machine and so I can not run the debugger.  In a few attempts, the virtual machine did attach, but the lights on the USB multilink turn off and a message appears in XP Mode that the USB device has become non-functional.  I have tried multiple PE debuggers and encountered the same problem.


Method #2

I installed codewarrior 7.1.1 directly on my Windows 7 64 bit machine.  There were a view warnings/errors during installation, but I ignored these and codewarrior seemed to install ok.  I was able to compile the code.  The USB Multilink 2.0 device shows up in the windows devices list.  However, when I try to connect or run the debugger, Codewarrior produces the following error "ColdFire PE Protocol Adapter: No USB connection found" message.


I appreciate your help.